We are continuing to monitor for any further issues.
Posted May 08, 2026 - 12:09 EDT
Monitoring
A fix has been implemented, and Class services are now operating normally. We are continuing to monitor for any further issues.
Posted May 08, 2026 - 11:31 EDT
Update
We are continuing to work closely with AWS to resolve the issue. We will provide more information when it is available. More details on the issue can be found on the AWS Health Dashboard: https://health.aws.amazon.com/health/status.
Posted May 08, 2026 - 10:50 EDT
Update
We are continuing to work closely with AWS to resolve the issue. We will provide more information when it is available. More details on the issue can be found on the AWS Health Dashboard: https://health.aws.amazon.com/health/status.
Posted May 08, 2026 - 10:17 EDT
Identified
We have identified that the service disruption is related to an AWS incident affecting multiple services in the N. Virginia region. Our engineering team is working with AWS to mitigate the issue and restore full service as quickly as possible.
At approximately 9:05 AM EDT on Friday, May 8, 2026, a subset of users in a single pod in the Class hosted environment started experiencing issues joining classes. The Class Engineering team is engaged and actively investigating.
Posted May 08, 2026 - 09:37 EDT
This incident affected: Class for Zoom (Class US) and Class for Teams (Class for Teams US).